Cloud Foundry Logo

CVE-2019-11271: Bosh Deployment logs leak sensitive information


Share

CVE-2019-11271: Bosh Deployment logs leak sensitive information

Severity

Medium

Vendor

Cloud Foundry Foundation

Affected Cloud Foundry Products and Versions

  • BOSH
    • 270 versions prior to v270.1.1

Description

Cloud Foundry BOSH 270.x versions prior to v270.1.1, contain a BOSH Director that does not properly redact credentials when configured to use a MySQL database. A local authenticated malicious user may read any credentials that are contained in a BOSH manifest.

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • BOSH
    • Upgrade 270 versions to v270.1.1 or greater

History

2019-06-21: Affected versions updated.

2019-06-17: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES