Cloud Foundry Logo

CVE-2019-3789: Gorouter allows space developer to hijack route services hosted outside the platform


Share

CVE-2019-3789: Gorouter allows space developer to hijack route services hosted outside the platform

Severity

High

Vendor

Cloud Foundry Foundation

Affected Cloud Foundry Products and Versions

  • CF Routing
    • All versions prior to 0.188.0

Description

Cloud Foundry Routing Release, all versions prior to 0.188.0, contains a vulnerability that can hijack the traffic to route services hosted outside the platform. A user with space developer permissions can create a private domain that shadows the external domain of the route service, and map that route to an app. When the gorouter receives traffic destined for the external route service, this traffic will instead be directed to the internal app using the shadow route.

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • CF Routing
    • Upgrade All versions to 0.188.0 or greater

History

2019-04-08: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES