Cloud Foundry Logo

CVE-2020-5420: Gorouter is vulnerable to DoS attack via invalid HTTP responses

By: | September 1, 2020

Share

Severity

High

Vendor

Cloud Foundry Foundation

Description

Cloud Foundry Routing (Gorouter) versions prior to 0.206.0 allow a malicious developer with “cf push” access to cause denial-of-service to the CF cluster by pushing an app that returns specially crafted HTTP responses that crash the Gorouters.

Affected Cloud Foundry Products and Versions

Severity is high unless otherwise noted.

  • Routing
    • All versions prior to 0.206.0
  • CF Deployment
    • All versions prior to 13.15.0

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • Routing
    • Upgrade all versions to 0.206.0 or greater
  • CF Deployment
    • Upgrade all versions to 13.15.0 or greater

History

2020-09-01: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES