Cloud Foundry Logo

CF Deployment and Percona XtraDB Cluster Release are vulnerable to various MySQL vulnerabilities


Share

Severity

Medium

Vendor

Cloud Foundry Foundation

Description

Cloud Foundry Deployment, through its consumption of Percona XtraDB Cluster Release, is vulnerable to various MySQL vulnerabilites patched in the October 2019 Critical Patch Update, including:

  • CVE-2019-2910
  • CVE-2019-2911
  • CVE-2019-2914
  • CVE-2019-2922
  • CVE-2019-2923
  • CVE-2019-2924
  • CVE-2019-2938
  • CVE-2019-2946
  • CVE-2019-2960
  • CVE-2019-2974
  • CVE-2019-2993
  • CVE-2019-5443

Affected Cloud Foundry Products and Versions

  • Percona XtraDB Cluster Release
    • All versions prior to v0.22.0
  • CF Deployment
    • All versions prior to v12.22.0

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • Percona XtraDB Cluster Release
    • Upgrade All versions to v0.22.0 or greater
  • CF Deployment
    • Upgrade All versions to v12.22.0 or greater

History

2020-01-27: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES