Cloud Foundry Logo

USN-3256-2: Linux kernel (HWE) vulnerability


Share

USN-3256-2: Linux kernel (HWE) vulnerability

Severity

High

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 14.04

Description

USN-3256-1 fixed vulnerabilities in the Linux kernel for Ubuntu 14.04 LTS, Ubuntu 16.04 LTS, and Ubuntu 16.10. This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel for each of the respective prior Ubuntu LTS releases.

Andrey Konovalov discovered that the AF_PACKET implementation in the Linux kernel did not properly validate certain block-size data. A local attacker could use this to cause a denial of service (system crash).

Affected Cloud Foundry Products and Versions

Severity is high unless otherwise noted.

  • Cloud Foundry BOSH stemcells are vulnerable, including:
    • 3151.x versions prior to 3151.15
    • 3233.x versions prior to 3233.17
    • 3263.x versions prior to 3263.23
    • 3312.x versions prior to 3312.23
    • 3363.x versions prior to 3363.15
    • All other stemcells not listed.

Mitigation

OSS users are strongly encouraged to follow one of the mitigations below:

  • The Cloud Foundry project recommends upgrading the following BOSH stemcells:
    • Upgrade 3151.x versions to 3151.15 or later
    • Upgrade 3233.x versions to 3233.17 or later
    • Upgrade 3263.x versions to 3263.23 or later
    • Upgrade 3312.x versions to 3312.23 or later
    • Upgrade 3363.x versions to 3363.15 or later
    • All other stemcells should be upgraded to the latest version.

References

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES