Cloud Foundry Logo

USN-3304-1: Sudo vulnerability


Share

USN-3304-1: Sudo vulnerability

Severity

High

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 14.04

Description

It was discovered that Sudo did not properly parse the contents of /proc/[pid]/stat when attempting to determine its controlling tty. A local attacker in some configurations could possibly use this to overwrite any file on the filesystem, bypassing intended permissions.

Affected Cloud Foundry Products and Versions

Severity is high unless otherwise noted.

  • Cloud Foundry BOSH stemcells are vulnerable, including:
    • 3263.x versions prior to 3263.27
    • 3312.x versions prior to 3312.28
    • 3363.x versions prior to 3363.25
    • All other stemcells not listed.
  • All versions of Cloud Foundry cflinuxfs2 prior to 1.126.0

Mitigation

OSS users are strongly encouraged to follow one of the mitigations below:

  • The Cloud Foundry project recommends upgrading the following BOSH stemcells:
    • Upgrade 3263.x versions prior to 3263.27
    • Upgrade 3312.x versions prior to 3312.28
    • Upgrade 3363.x versions prior to 3363.25
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs2 version 1.126.0 or later.

References

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES