Cloud Foundry Logo

USN-3415-1: tcpdump vulnerabilities

By: | September 21, 2017

Share

USN-3415-1: tcpdump vulnerabilities

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 14.04

Description

Wilfried Kirsch discovered a buffer overflow in the SLIP decoder in tcpdump. A remote attacker could use this to cause a denial of service (application crash) or possibly execute arbitrary code. (CVE-2017-11543)

Bhargava Shastry discovered a buffer overflow in the bitfield converter utility function bittok2str_internal() in tcpdump. A remote attacker could use this to cause a denial of service (application crash) or possibly execute arbitrary code. (CVE-2017-13011)

Otto Airamo and Antti Levomäki discovered logic errors in different protocol parsers in tcpdump that could lead to an infinite loop. A remote attacker could use these to cause a denial of service (application hang). CVE-2017-12989CVE-2017-12990CVE-2017-12995CVE-2017-12997)

Otto Airamo, Brian Carpenter, Yannick Formaggio, Kamil Frankowicz, Katie Holly, Kim Gwan Yeong, Antti Levomäki, Henri Salo, and Bhargava Shastry discovered out-of-bounds reads in muliptle protocol parsers in tcpdump. A remote attacker could use these to cause a denial of service (application crash). (CVE-2017-11108CVE-2017-11541CVE-2017-11542CVE-2017-12893CVE-2017-12894CVE-2017-12895CVE-2017-12896CVE-2017-12897CVE-2017-12898CVE-2017-12899CVE-2017-12900CVE-2017-12901CVE-2017-12902CVE-2017-12985CVE-2017-12986CVE-2017-12987CVE-2017-12988CVE-2017-12991CVE-2017-12992CVE-2017-12993CVE-2017-12994CVE-2017-12996CVE-2017-12998CVE-2017-12999CVE-2017-13000CVE-2017-13001CVE-2017-13002CVE-2017-13003CVE-2017-13004CVE-2017-13005CVE-2017-13006CVE-2017-13007CVE-2017-13008CVE-2017-13009CVE-2017-13010CVE-2017-13012CVE-2017-13013CVE-2017-13014CVE-2017-13015CVE-2017-13016CVE-2017-13017CVE-2017-13018CVE-2017-13019CVE-2017-13020CVE-2017-13021CVE-2017-13022CVE-2017-13023CVE-2017-13024CVE-2017-13025CVE-2017-13026CVE-2017-13027CVE-2017-13028CVE-2017-13029CVE-2017-13030CVE-2017-13031CVE-2017-13032CVE-2017-13033CVE-2017-13034CVE-2017-13035CVE-2017-13036CVE-2017-13037CVE-2017-13038CVE-2017-13039CVE-2017-13040CVE-2017-13041CVE-2017-13042CVE-2017-13043CVE-2017-13044CVE-2017-13045CVE-2017-13046CVE-2017-13047CVE-2017-13048CVE-2017-13049CVE-2017-13050CVE-2017-13051CVE-2017-13052CVE-2017-13053CVE-2017-13054CVE-2017-13055CVE-2017-13687CVE-2017-13688CVE-2017-13689CVE-2017-13690CVE-2017-13725)

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • Cloud Foundry BOSH stemcells are vulnerable, including:
    • 3312.x versions prior to 3312.38
    • 3363.x versions prior to 3363.37
    • 3421.x versions prior to 3421.26
    • 3445.x versions prior to 3445.11
    • All other stemcells not listed.
  • All versions of Cloud Foundry cflinuxfs2 prior to 1.155.0

Mitigation

OSS users are strongly encouraged to follow one of the mitigations below:

  • The Cloud Foundry project recommends upgrading the following BOSH stemcells:
    • Upgrade 3312.x versions prior to 3312.38
    • Upgrade 3363.x versions prior to 3363.37
    • Upgrade 3421.x versions prior to 3421.26
    • Upgrade 3445.x versions prior to 3445.11
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs2 version 1.155.0 or later.

References

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES