Cloud Foundry Logo

USN-3454-1: libffi vulnerability


Share

USN-3454-1: libffi vulnerability

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 14.04

Description

It was discovered that libffi incorrectly enforced an executable stack. An attacker could possibly use this issue, in combination with another vulnerability, to facilitate executing arbitrary code.

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • Cloud Foundry BOSH stemcells are vulnerable, including:
    • 3363.x versions prior to 3363.40
    • 3421.x versions prior to 3421.29
    • 3445.x versions prior to 3445.15
    • All other stemcells not listed.
  • All versions of Cloud Foundry cflinuxfs2 prior to 1.161.0

Mitigation

OSS users are strongly encouraged to follow one of the mitigations below:

  • The Cloud Foundry project recommends upgrading the following BOSH stemcells:
    • Upgrade 3363.x versions prior to 3363.40
    • Upgrade 3421.x versions prior to 3421.29
    • Upgrade 3445.x versions prior to 3445.15
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs2 version 1.161.0 or later.

References

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES