Cloud Foundry Logo

USN-3522-2: Linux (Xenial HWE) vulnerability


Share

USN-3522-2: Linux (Xenial HWE) vulnerability

Severity

Critical

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 14.04

Description

USN-3522-1 fixed vulnerabilities in the Linux kernel for Ubuntu 16.04 LTS. This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel from Ubuntu 16.04 LTS for Ubuntu 14.04 LTS.

Jann Horn discovered that microprocessors utilizing speculative execution and indirect branch prediction may allow unauthorized memory reads via sidechannel attacks. This flaw is known as Meltdown. A local attacker could use this to expose sensitive information, including kernel memory. (CVE-2017-5754)

Please Note: These stemcells address the critical vulnerability in Ubuntu associated with Meltdown. This update may include degradations to performance. The Cloud Foundry Project will be performing additional performance testing and will make updates to this notice as more information is available.

Affected Cloud Foundry Products and Versions

Severity is critical unless otherwise noted.

  • Cloud Foundry BOSH stemcells are vulnerable, including:
    • 3312.x versions prior to 3312.49
    • 3363.x versions prior to 3363.45
    • 3421.x versions prior to 3421.35
    • 3445.x versions prior to 3445.21
    • 3468.x versions prior to 3468.16
    • All other stemcells not listed.

Mitigation

OSS users are strongly encouraged to follow one of the mitigations below:

  • The Cloud Foundry project recommends upgrading the following BOSH stemcells:
    • Upgrade 3312.x versions to 3312.49
    • Upgrade 3363.x versions to 3363.45
    • Upgrade 3421.x versions to 3421.35
    • Upgrade 3445.x versions to 3445.21
    • Upgrade 3468.x versions to 3468.16
    • All other stemcells should be upgraded to the latest version available on bosh.io.

References

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES