USN-3684-1: Perl vulnerability


Share

USN-3684-1: Perl vulnerability

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 14.04

Description

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • Cloud Foundry BOSH stemcells are vulnerable, including:
    • 3586.x versions prior to 3586.24
    • 3541.x versions prior to 3541.34
    • 3468.x versions prior to 3468.51
    • 3445.x versions prior to 3445.51
    • 3421.x versions prior to 3421.66
    • 3363.x versions prior to 3363.65
    • All other stemcells not listed.
  • All versions of Cloud Foundry cflinuxfs2 prior to 1.217.0

Mitigation

OSS users are strongly encouraged to follow one of the mitigations below:

  • The Cloud Foundry project recommends upgrading the following BOSH stemcells:
    • Upgrade 3586.x versions to 3586.24
    • Upgrade 3541.x versions to 3541.34
    • Upgrade 3468.x versions to 3468.51
    • Upgrade 3445.x versions to 3445.51
    • Upgrade 3421.x versions to 3421.66
    • Upgrade 3363.x versions to 3363.65
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs2 version 1.217.0 or later.

References

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES