Cloud Foundry Logo

USN-3791-1: Git vulnerability


Share

USN-3791-1: Git vulnerability

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 14.04
  • Canonical Ubuntu 18.04

Description

It was discovered that git did not properly validate git submodule urls or paths. A remote attacker could possibly use this to craft a git repository that causes arbitrary code execution when recursive operations are used.

CVEs contained in this USN include: CVE-2018-17456

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • All versions of Cloud Foundry cflinuxfs2 prior to 1.242.0
  • All versions of Cloud Foundry cflinuxfs3 prior to 0.29.0

Mitigation

Users of affected products are strongly encouraged to follow one of the mitigations below:

  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs2 version 1.242.0 or later.
  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs3 version 0.29.0 or later.

References

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES