Cloud Foundry Logo

USN-3882-1: curl vulnerabilities

By: | February 15, 2019

Share

USN-3882-1: curl vulnerabilities

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 14.04
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04

Description

Wenxiang Qian discovered that curl incorrectly handled certain NTLM authentication messages. A remote attacker could possibly use this issue to cause curl to crash, resulting in a denial of service. This issue only applied to Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 18.10. (CVE-2018-16890)

Wenxiang Qian discovered that curl incorrectly handled certain NTLMv2 authentication messages. A remote attacker could use this issue to cause curl to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only applied to Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 18.10. (CVE-2019-3822)

Brian Carpenter discovered that curl incorrectly handled certain SMTP responses. A remote attacker could possibly use this issue to cause curl to crash, resulting in a denial of service. (CVE-2019-3823)

CVEs contained in this USN include: CVE-2018-16890, CVE-2019-3822, CVE-2019-3823

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • Cloud Foundry BOSH trusty-stemcells are vulnerable, including:
    • 3586.x versions prior to 3586.79
    • 3541.x versions prior to 3541.80
    • 3468.x versions prior to 3468.101
    • 3445.x versions prior to 3445.97
    • 3421.x versions prior to 3421.117
    • All other stemcells not listed.
  • Cloud Foundry BOSH xenial-stemcells are vulnerable, including:
    • 250.x versions prior to 250.9
    • 170.x versions prior to 170.30
    • 97.x versions prior to 97.57
    • All other stemcells not listed.
  • All versions of Cloud Foundry cflinuxfs2 prior to 1.264.0
  • All versions of Cloud Foundry cflinuxfs3 prior to 0.58.0

Mitigation

Users of affected products are strongly encouraged to follow one of the mitigations below:

  • The Cloud Foundry project recommends upgrading the following BOSH trusty-stemcells:
    • Upgrade 3586.x versions to 3586.79
    • Upgrade 3541.x versions to 3541.80
    • Upgrade 3468.x versions to 3468.101
    • Upgrade 3445.x versions to 3445.97
    • Upgrade 3421.x versions to 3421.117
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • The Cloud Foundry project recommends upgrading the following BOSH xenial-stemcells:
    • Upgrade 250.x versions to 250.9
    • Upgrade 170.x versions to 170.30
    • Upgrade 97.x versions to 97.57
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs2 version 1.264.0 or later.
  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs3 version 0.58.0 or later.

References

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES