Cloud Foundry Logo

USN-3947-1: Libxslt vulnerability


Share

USN-3947-1: Libxslt vulnerability

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 14.04
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04

Description

It was discovered that Libxslt incorrectly handled certain documents. An attacker could possibly use this issue to access sensitive information.

CVEs contained in this USN include: CVE-2019-11068

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • Cloud Foundry BOSH trusty-stemcells are vulnerable, including:
    • 3586.x versions prior to 3586.100
    • 3541.x versions prior to 3541.98
    • 3468.x versions prior to 3468.112
    • 3445.x versions prior to 3445.111
    • 3421.x versions prior to 3421.127
    • All other stemcells not listed.
  • Cloud Foundry BOSH xenial-stemcells are vulnerable, including:
    • 250.x versions prior to 250.38
    • 170.x versions prior to 170.51
    • 97.x versions prior to 97.82
    • All other stemcells not listed.
  • All versions of Cloud Foundry cflinuxfs2 prior to 1.281.0
  • All versions of Cloud Foundry cflinuxfs3 prior to 0.81.0

Mitigation

Users of affected products are strongly encouraged to follow one of the mitigations below:

  • The Cloud Foundry project recommends upgrading the following BOSH trusty-stemcells:
    • Upgrade 3586.x versions to 3586.100
    • Upgrade 3541.x versions to 3541.98
    • Upgrade 3468.x versions to 3468.112
    • Upgrade 3445.x versions to 3445.111
    • Upgrade 3421.x versions to 3421.127
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • The Cloud Foundry project recommends upgrading the following BOSH xenial-stemcells:
    • Upgrade 250.x versions to 250.38
    • Upgrade 170.x versions to 170.51
    • Upgrade 97.x versions to 97.82
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs2 version 1.281.0 or later.
  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs3 version 0.81.0 or later.

References

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES