Cloud Foundry Logo

USN-4034-1: ImageMagick vulnerabilities


Share

USN-4034-1: ImageMagick vulnerabilities

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 18.04

Description

It was discovered that ImageMagick incorrectly handled certain malformed image files. If a user or automated system using ImageMagick were tricked into opening a specially crafted image, an attacker could exploit this to cause a denial of service or possibly execute code with the privileges of the user invoking the program.

Due to a large number of issues discovered in GhostScript that prevent it from being used by ImageMagick safely, the update for Ubuntu 18.10 and Ubuntu 19.04 includes a default policy change that disables support for the Postscript and PDF formats in ImageMagick. This policy can be overridden if necessary by using an alternate ImageMagick policy configuration.

CVEs contained in this USN include: CVE-2018-14434, CVE-2018-16323, CVE-2018-16644, CVE-2018-16645, CVE-2017-12805, CVE-2017-12806, CVE-2018-15607, CVE-2018-16412, CVE-2018-16413, CVE-2018-17965, CVE-2018-17966, CVE-2018-18016, CVE-2018-18023, CVE-2018-18024, CVE-2018-18025, CVE-2018-18544, CVE-2018-20467, CVE-2019-10131, CVE-2019-10649, CVE-2019-10650, CVE-2019-11470, CVE-2019-11472, CVE-2019-11597, CVE-2019-11598, CVE-2019-7175, CVE-2019-7395, CVE-2019-7396, CVE-2019-7397, CVE-2019-7398, CVE-2019-9956

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • All versions of Cloud Foundry cflinuxfs3 prior to 0.106.0

Mitigation

Users of affected products are strongly encouraged to follow one of the mitigations below:

  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs3 version 0.106.0 or later.

References

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES