USN-4164-1: Libxslt vulnerabilities
- Canonical Ubuntu 14.04
- Canonical Ubuntu 16.04
- Canonical Ubuntu 18.04
It was discovered that Libxslt incorrectly handled certain documents. An attacker could possibly use this issue to access sensitive information. This issue not affected Ubuntu 19.10. (CVE-2019-13117, CVE-2019-13118)
It was discovered that Libxslt incorrectly handled certain documents. An attacker could possibly use this issue to execute arbitrary code. (CVE-2019-18197)
CVEs contained in this USN include: CVE-2019-13117, CVE-2019-13118, CVE-2019-18197
Affected Cloud Foundry Products and Versions
Severity is medium unless otherwise noted.
- Cloud Foundry BOSH xenial-stemcells are vulnerable, including:
- 456.x versions prior to 456.51
- 315.x versions prior to 315.126
- 250.x versions prior to 250.142
- 170.x versions prior to 170.162
- 97.x versions prior to 97.187
- All other stemcells not listed.
- All versions of Cloud Foundry cflinuxfs3 prior to 0.137.0
Users of affected products are strongly encouraged to follow one of the mitigations below:
- The Cloud Foundry project recommends upgrading the following BOSH xenial-stemcells:
- Upgrade 456.x versions to 456.51
- Upgrade 315.x versions to 315.126
- Upgrade 250.x versions to 250.142
- Upgrade 170.x versions to 170.162
- Upgrade 97.x versions to 97.187
- All other stemcells should be upgraded to the latest version available on bosh.io.
- The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs3 version 0.137.0 or later.