Cloud Foundry Logo

USN-4182-1: Intel Microcode update

By: | November 21, 2019

Share

USN-4182-1: Intel Microcode update

Severity

High

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 16.04

Description

Stephan van Schaik, Alyssa Milburn, Sebastian Österlund, Pietro Frigo, Kaveh Razavi, Herbert Bos, Cristiano Giuffrida, Giorgi Maisuradze, Moritz Lipp, Michael Schwarz, Daniel Gruss, and Jo Van Bulck discovered that Intel processors using Transactional Synchronization Extensions (TSX) could expose memory contents previously stored in microarchitectural buffers to a malicious process that is executing on the same CPU core. A local attacker could use this to expose sensitive information. (CVE-2019-11135)

It was discovered that certain Intel Xeon processors did not properly restrict access to a voltage modulation interface. A local privileged attacker could use this to cause a denial of service (system crash). (CVE-2019-11139)

CVEs contained in this USN include: CVE-2019-11135, CVE-2019-11139

Affected Cloud Foundry Products and Versions

Severity is high unless otherwise noted.

  • Cloud Foundry BOSH xenial-stemcells are vulnerable, including:
    • 456.x versions prior to 456.69
    • 315.x versions prior to 315.141
    • 250.x versions prior to 250.157
    • 170.x versions prior to 170.175
    • 97.x versions prior to 97.202
    • All other stemcells not listed.

Mitigation

Users of affected products are strongly encouraged to follow one of the mitigations below:

  • The Cloud Foundry project recommends upgrading the following BOSH xenial-stemcells:
    • Upgrade 456.x versions to 456.69
    • Upgrade 315.x versions to 315.141
    • Upgrade 250.x versions to 250.157
    • Upgrade 170.x versions to 170.175
    • Upgrade 97.x versions to 97.202
    • All other stemcells should be upgraded to the latest version available on bosh.io.

References

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES