Cloud Foundry Logo
blog single gear
Security Advisory

USN-4309-1: Vim vulnerabilities

USN-4309-1: Vim vulnerabilities

Severity

Low

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 14.04
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04

Description

It was discovered that Vim incorrectly handled certain sources. An attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 12.04 ESM, Ubuntu 14.04 ESM and Ubuntu 16.04 LTS (CVE-2017-1110)

It was discovered that Vim incorrectly handled certain files. An attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 12.04 ESM and Ubuntu 14.04 ESM. (CVE-2017-5953)

It was discovered that Vim incorrectly handled certain inputs. An attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 16.06 LTS. (CVE-2018-20786)

It was discovered that Vim incorrectly handled certain inputs. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. This issue only affected Ubuntu 18.04 LTS and Ubuntu 19.10. (CVE-2019-20079)

It was discovered that Vim incorrectly handled certain files. An attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 12.04 ESM, Ubuntu 14.04 ESM and Ubuntu 16.04 LTS. (CVE-2017-6349, CVE-2017-6350)

CVEs contained in this USN include: CVE-2017-11109, CVE-2017-5953, CVE-2017-6349, CVE-2017-6350, CVE-2018-20786, CVE-2019-20079.

Affected Cloud Foundry Products and Versions

Severity is low unless otherwise noted.

  • cflinuxfs3
    • All versions prior to 0.172.0
  • Xenial Stemcells
    • 97.x versions prior to 97.241
    • 170.x versions prior to 170.211
    • 250.x versions prior to 250.190
    • 315.x versions prior to 315.175
    • 456.x versions prior to 456.104
    • 621.x versions prior to 621.64
    • All other stemcells not listed.
  • CF Deployment
    • All versions prior to v12.39.0

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • cflinuxfs3
    • Upgrade All versions to 0.172.0 or greater
  • Xenial Stemcells
    • Upgrade 97.x versions to 97.241 or greater
    • Upgrade 170.x versions to 170.211 or greater
    • Upgrade 250.x versions to 250.190 or greater
    • Upgrade 315.x versions to 315.175 or greater
    • Upgrade 456.x versions to 456.104 or greater
    • Upgrade 621.x versions to 621.64 or greater
    • All other stemcells should be upgraded to the latest version available onĀ bosh.io.
  • CF Deployment
    • Upgrade All versions to v12.39.0 or greater

History

2020-03-23: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES