Cloud Foundry Logo
blog single gear
Security Advisory

USN-5013-1: systemd vulnerabilities

Severity

High

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 18.04

Description

It was discovered that systemd incorrectly handled certain mount paths. A local attacker could possibly use this issue to cause systemd to crash, resulting in a denial of service. (CVE-2021-33910)

Mitchell Frank discovered that systemd incorrectly handled DHCP FORCERENEW packets. A remote attacker could possibly use this issue to reconfigure servers. (CVE-2020-13529)

CVEs contained in this USN include: CVE-2020-13529, CVE-2021-33910.

Affected Cloud Foundry Products and Versions

Severity is high unless otherwise noted.

  • Bionic Stemcells
    • 1.x versions prior to 1.20
    • All other stemcells not listed.
  • cflinuxfs3
    • All versions prior to 0.250.0
  • CF Deployment
    • All versions prior to 16.22.0

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • Bionic Stemcells
    • Upgrade 1.x versions to 1.20 or greater
    • All other stemcells should be upgraded to the latest version available onĀ bosh.io.
  • cflinuxfs3
    • Upgrade all versions to 0.250.0 or greater
  • CF Deployment
    • Upgrade all versions to 16.22.0 or greater

History

2021-09-03: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES