Cloud Foundry Logo
blog single gear
Security Advisory

USN-5147-1: Vim vulnerabilities

Severity

Low

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04

Description

Several security issues were fixed in Vim.

CVEs contained in this USN include: CVE-2017-17087, CVE-2019-20807.

Affected Cloud Foundry Products and Versions

Severity is low unless otherwise noted.

  • Bionic Stemcells
    • 1.x versions prior to 1.41
    • All other stemcells not listed.
  • cflinuxfs3
    • All versions prior to 0.267.0
  • CF Deployment
    • All versions prior to 17.1.0

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • Bionic Stemcells
    • Upgrade 1.x versions to 1.41 or greater
    • All other stemcells should be upgraded to the latest version available onĀ bosh.io.
  • cflinuxfs3
    • Upgrade all versions to 0.267.0 or greater
  • CF Deployment
    • Upgrade all versions to 17.1.0 or greater

History

2022-01-20: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES