Cloud Foundry Logo
blog single gear
Security Advisory

USN-5425-1: PCRE vulnerabilities

Severity

Low

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04

Description

Yunho Kim discovered that PCRE incorrectly handled memory when handling certain regular expressions. An attacker could possibly use this issue to cause applications using PCRE to expose sensitive information. This issue only affects Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, Ubuntu 21.10 and Ubuntu 22.04 LTS. (CVE-2019-20838) It was discovered that PCRE incorrectly handled memory when handling certain regular expressions. An attacker could possibly use this issue to cause applications using PCRE to have unexpected behavior. This issue only affects Ubuntu 14.04 ESM, Ubuntu 16.04 ESM, Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-14155) Update Instructions: Run `sudo ua fix USN-5425-1` to fix the vulnerability. The problem can be corrected by updating your system to the following package versions: pcregrep – 2:8.38-3.1ubuntu0.1~esm1 libpcre3-dev – 2:8.38-3.1ubuntu0.1~esm1 libpcre3 – 2:8.38-3.1ubuntu0.1~esm1 libpcrecpp0v5 – 2:8.38-3.1ubuntu0.1~esm1 libpcre16-3 – 2:8.38-3.1ubuntu0.1~esm1 libpcre32-3 – 2:8.38-3.1ubuntu0.1~esm1 Available with UA Infra or UA Desktop: https://ubuntu.com/advantage

CVEs contained in this USN include: CVE-2019-20838, CVE-2020-14155.

Affected Cloud Foundry Products and Versions

Severity is low unless otherwise noted.

  • Bionic Stemcells
    • 1.x versions prior to 1.85
    • All other stemcells not listed.
  • cflinuxfs3
    • All versions prior to 0.299.0
  • CF Deployment
    • All versions prior to 21.0.0, or later versions with Bionic Stemcells prior to 1.85 or Xenial Stemcells prior to 621.244

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • Bionic Stemcells
    • Upgrade 1.x versions to 1.85 or greater
    • All other stemcells should be upgraded to the latest version available onĀ bosh.io.
  • cflinuxfs3
    • Upgrade all versions to 0.299.0 or greater
  • CF Deployment
    • Upgrade all versions to 21.0.0 or greater, upgrade Bionic Stemcells to 1.85 or greater, and upgrade Xenial Stemcells to 621.244 or greater

History

2022-07-29: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES