Cloud Foundry Logo
blog single gear
Security Advisory

USN-5519-1: Python vulnerability

USN-5519-1: Python vulnerability




Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04


It was discovered that Python incorrectly handled certain inputs. An attacker could possibly use this issue to execute arbitrary code. Update Instructions: Run `sudo ua fix USN-5519-1` to fix the vulnerability. The problem can be corrected by updating your system to the following package versions: python2.7-dev – 2.7.12-1ubuntu0~16.04.18+esm2 python2.7-doc – 2.7.12-1ubuntu0~16.04.18+esm2 libpython2.7-stdlib – 2.7.12-1ubuntu0~16.04.18+esm2 libpython2.7-minimal – 2.7.12-1ubuntu0~16.04.18+esm2 libpython2.7 – 2.7.12-1ubuntu0~16.04.18+esm2 libpython2.7-testsuite – 2.7.12-1ubuntu0~16.04.18+esm2 python2.7 – 2.7.12-1ubuntu0~16.04.18+esm2 idle-python2.7 – 2.7.12-1ubuntu0~16.04.18+esm2 python2.7-examples – 2.7.12-1ubuntu0~16.04.18+esm2 libpython2.7-dev – 2.7.12-1ubuntu0~16.04.18+esm2 python2.7-minimal – 2.7.12-1ubuntu0~16.04.18+esm2 Available with UA Infra or UA Desktop: libpython3.5-stdlib – 3.5.2-2ubuntu0~16.04.13+esm3 python3.5-venv – 3.5.2-2ubuntu0~16.04.13+esm3 python3.5-doc – 3.5.2-2ubuntu0~16.04.13+esm3 python3.5-dev – 3.5.2-2ubuntu0~16.04.13+esm3 libpython3.5-dev – 3.5.2-2ubuntu0~16.04.13+esm3 libpython3.5-minimal – 3.5.2-2ubuntu0~16.04.13+esm3 python3.5 – 3.5.2-2ubuntu0~16.04.13+esm3 idle-python3.5 – 3.5.2-2ubuntu0~16.04.13+esm3 libpython3.5-testsuite – 3.5.2-2ubuntu0~16.04.13+esm3 python3.5-examples – 3.5.2-2ubuntu0~16.04.13+esm3 python3.5-minimal – 3.5.2-2ubuntu0~16.04.13+esm3 libpython3.5 – 3.5.2-2ubuntu0~16.04.13+esm3 Available with UA Infra or UA Desktop:

CVEs contained in this USN include: CVE-2015-20107.

Affected Cloud Foundry Products and Versions

Severity is low unless otherwise noted.

  • Bionic Stemcells
    • 1.x versions prior to 1.92
    • All other stemcells not listed.
  • cflinuxfs3
    • All versions prior to 0.311.0
  • CF Deployment
    • All versions prior to 21.7.0, or later versions with Bionic Stemcells prior to 1.92 or Xenial Stemcells prior to 621.261


Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • Bionic Stemcells
    • Upgrade 1.x versions to 1.92 or greater
    • All other stemcells should be upgraded to the latest version available on
  • cflinuxfs3
    • Upgrade all versions to 0.311.0 or greater
  • CF Deployment
    • Upgrade all versions to 21.7.0 or greater, upgrade Bionic Stemcells to 1.92 or greater, and upgrade Xenial Stemcells to 621.261 or greater


2022-08-26: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR