Cloud Foundry Logo
blog single gear
Security Advisory

USN-5960-1: Python vulnerability




Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04
  • Canonical Ubuntu 22.04


Yebo Cao discovered that Python incorrectly handled certain URLs. An attacker could possibly use this issue to bypass blocklisting methods by supplying a URL that starts with blank characters. Update Instructions: Run `sudo pro fix USN-5960-1` to fix the vulnerability. The problem can be corrected by updating your system to the following package versions: python2.7-dev – 2.7.12-1ubuntu0~16.04.18+esm4 python2.7-doc – 2.7.12-1ubuntu0~16.04.18+esm4 libpython2.7-stdlib – 2.7.12-1ubuntu0~16.04.18+esm4 libpython2.7-minimal – 2.7.12-1ubuntu0~16.04.18+esm4 libpython2.7 – 2.7.12-1ubuntu0~16.04.18+esm4 libpython2.7-testsuite – 2.7.12-1ubuntu0~16.04.18+esm4 python2.7 – 2.7.12-1ubuntu0~16.04.18+esm4 idle-python2.7 – 2.7.12-1ubuntu0~16.04.18+esm4 python2.7-examples – 2.7.12-1ubuntu0~16.04.18+esm4 libpython2.7-dev – 2.7.12-1ubuntu0~16.04.18+esm4 python2.7-minimal – 2.7.12-1ubuntu0~16.04.18+esm4 Available with Ubuntu Pro (Infra-only): libpython3.5-stdlib – 3.5.2-2ubuntu0~16.04.13+esm7 python3.5-venv – 3.5.2-2ubuntu0~16.04.13+esm7 python3.5-doc – 3.5.2-2ubuntu0~16.04.13+esm7 python3.5-dev – 3.5.2-2ubuntu0~16.04.13+esm7 libpython3.5-dev – 3.5.2-2ubuntu0~16.04.13+esm7 libpython3.5-minimal – 3.5.2-2ubuntu0~16.04.13+esm7 python3.5 – 3.5.2-2ubuntu0~16.04.13+esm7 idle-python3.5 – 3.5.2-2ubuntu0~16.04.13+esm7 libpython3.5-testsuite – 3.5.2-2ubuntu0~16.04.13+esm7 python3.5-examples – 3.5.2-2ubuntu0~16.04.13+esm7 python3.5-minimal – 3.5.2-2ubuntu0~16.04.13+esm7 libpython3.5 – 3.5.2-2ubuntu0~16.04.13+esm7 Available with Ubuntu Pro (Infra-only):

CVEs contained in this USN include: CVE-2023-24329.

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • Bionic Stemcells
    • 1.x versions prior to 1.188
    • All other stemcells not listed.
  • cflinuxfs3
    • All versions prior to 0.357.0
  • cflinuxfs4
    • All versions prior to 0.73.0
  • Jammy Stemcells
    • 1.x versions prior to 1.95
    • All other stemcells not listed.
  • CF Deployment
    • All versions prior to 27.4.0, or later versions with Jammy Stemcells prior to 1.95 or Bionic Stemcells prior to 1.188


Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • Bionic Stemcells
    • Upgrade 1.x versions to 1.188 or greater
    • All other stemcells should be upgraded to the latest version available on
  • cflinuxfs3
    • Upgrade all versions to 0.357.0 or greater
  • cflinuxfs4
    • Upgrade all versions to 0.73.0 or greater
  • Jammy Stemcells
    • Upgrade 1.x versions to 1.95 or greater
    • All other stemcells should be upgraded to the latest version available on
  • CF Deployment
    • Upgrade all versions to 27.4.0 or greater, upgrade Jammy Stemcells to 1.95 or greater, and upgrade Bionic Stemcells to 1.188 or greater


2023-04-29: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR