Cloud Foundry Logo
blog single gear
Security Advisory

USN-6600-1: MariaDB vulnerabilities




Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 22.04


Several security issues were discovered in MariaDB and this update includes new upstream MariaDB versions to fix these issues. MariaDB has been updated to 10.3.39 in Ubuntu 20.04 LTS, 10.6.16 in Ubuntu 22.04 LTS and 10.11.6 in Ubuntu 23.10. CVE-2022-47015 only affected the MariaDB packages in Ubuntu 20.04 LTS and Ubuntu 22.04 LTS. In addition to security fixes, the updated packages contain bug fixes, new features, and possibly incompatible changes. Update Instructions: Run `sudo pro fix USN-6600-1` to fix the vulnerability. The problem can be corrected by updating your system to the following package versions: mariadb-plugin-cracklib-password-check – 1:10.3.39-0ubuntu0.20.04.2 mariadb-backup – 1:10.3.39-0ubuntu0.20.04.2 mariadb-plugin-connect – 1:10.3.39-0ubuntu0.20.04.2 mariadb-plugin-spider – 1:10.3.39-0ubuntu0.20.04.2 libmariadbclient-dev – 1:10.3.39-0ubuntu0.20.04.2 libmariadb-dev – 1:10.3.39-0ubuntu0.20.04.2 libmariadb3 – 1:10.3.39-0ubuntu0.20.04.2 libmariadbd19 – 1:10.3.39-0ubuntu0.20.04.2 mariadb-client-core-10.3 – 1:10.3.39-0ubuntu0.20.04.2 mariadb-plugin-tokudb – 1:10.3.39-0ubuntu0.20.04.2 mariadb-plugin-mroonga – 1:10.3.39-0ubuntu0.20.04.2 mariadb-client – 1:10.3.39-0ubuntu0.20.04.2 mariadb-server-10.3 – 1:10.3.39-0ubuntu0.20.04.2 mariadb-server-core-10.3 – 1:10.3.39-0ubuntu0.20.04.2 mariadb-test-data – 1:10.3.39-0ubuntu0.20.04.2 mariadb-client-10.3 – 1:10.3.39-0ubuntu0.20.04.2 mariadb-plugin-rocksdb – 1:10.3.39-0ubuntu0.20.04.2 mariadb-plugin-gssapi-client – 1:10.3.39-0ubuntu0.20.04.2 libmariadbd-dev – 1:10.3.39-0ubuntu0.20.04.2 libmariadb-dev-compat – 1:10.3.39-0ubuntu0.20.04.2 mariadb-plugin-gssapi-server – 1:10.3.39-0ubuntu0.20.04.2 mariadb-server – 1:10.3.39-0ubuntu0.20.04.2 mariadb-common – 1:10.3.39-0ubuntu0.20.04.2 mariadb-plugin-oqgraph – 1:10.3.39-0ubuntu0.20.04.2 mariadb-test – 1:10.3.39-0ubuntu0.20.04.2 No subscription required

CVEs contained in this USN include: CVE-2023-22084, CVE-2022-47015.

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • cflinuxfs4
    • All versions prior to 1.69.0
  • CF Deployment
    • All versions prior to 37.5.0


Users of affected products are strongly encouraged to follow the mitigations below.

The Cloud Foundry project recommends upgrading the following releases:

  • cflinuxfs4
    • Upgrade all versions to 1.69.0 or greater
  • CF Deployment
    • Upgrade all versions to 37.5.0 or greater


2024-02-29: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR