Cloud Foundry Logo

CVE-2018-1190: XSS on UAA OpenID Connect check session iframe endpoint


Share

CVE-2018-1190: XSS on UAA OpenID Connect check session iframe endpoint

Severity

Medium

Vendor

Pivotal Cloud Foundry

Affected Pivotal Products and Versions

Severity is medium unless otherwise noted.

  • cf-release:
    • All versions prior to cf-release v270
  • cf-deployment:
    • No versions of cf-deployment are affected
  • UAA release:
    • v3.x prior to v3.20.2
  • UAA bosh release (uaa-release):
    • v30.x versions prior to v30.8
    • All other versions prior to v45.0

Description

A cross-site scripting (XSS) attack is possible in the clientId parameter of a request to the UAA OpenID Connect check session iframe endpoint used for single logout session management.

Mitigation

Users of affected versions should apply the following mitigation or upgrade:

  • Releases that have fixed this issue include:
    • cf-release: 270
    • UAA release: 3.20.2
    • UAA bosh release: 30.8, 45.0

Credit

This vulnerability was responsibly reported by Bosch.

References

History

2018-01-02: Initial vulnerability report published

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES