Cloud Foundry Logo

CVE-2018-1269: Loggregator does not properly close some TCP connections


Share

CVE-2018-1269: Loggregator does not properly close some TCP connections

Severity

Medium

Vendor

Cloud Foundry Foundation

Affected Cloud Foundry Products and Versions

  • You are using loggregator-release
    • Version 89.x prior to 89.5
    • Version 96.x prior to 96.1
    • Version 99.x prior to 99.1
    • Version 101.x prior to 101.9
    • Version 102.x prior to 102.2

Description

Cloud Foundry Loggregator, versions 89.x prior to 89.5 or 96.x prior to 96.1 or 99.x prior to 99.1 or 101.x prior to 101.9 or 102.x prior to 102.2, does not handle errors thrown while constructing certain http requests. A remote authenticated user may construct malicious requests to cause the traffic controller to leave dangling TCP connections, which could cause denial of service.

Mitigation

Users of affected versions should apply the following mitigations or upgrades:

  • Releases that have fixed this issue include:
    • loggregator-release versions 89.5, 96.1, 99.1, 101.9, 102.2

Credit

This issue was responsibly reported by the GE Digital Security Team.

History

2018-06-05: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES