Cloud Foundry Logo
blog single gear
Security Advisory

USN-4466-1: curl vulnerability

USN-4466-1: curl vulnerability

Severity

Low

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04

Description

Marc Aldorasi discovered that curl incorrectly handled the libcurl CURLOPT_CONNECT_ONLY option. This could result in data being sent to the wrong destination, possibly exposing sensitive information.

CVEs contained in this USN include: CVE-2020-8231.

Affected Cloud Foundry Products and Versions

Severity is low unless otherwise noted.

  • cflinuxfs3
    • All versions prior to 0.203.0
  • Xenial Stemcells
    • 250.x versions prior to 250.205
    • 315.x versions prior to 315.192
    • 456.x versions prior to 456.119
    • 621.x versions prior to 621.82
    • All other stemcells not listed.
  • CF Deployment
    • All versions prior to v13.17.0

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • cflinuxfs3
    • Upgrade All versions to 0.203.0 or greater
  • Xenial Stemcells
    • Upgrade 250.x versions to 250.205 or greater
    • Upgrade 315.x versions to 315.192 or greater
    • Upgrade 456.x versions to 456.119 or greater
    • Upgrade 621.x versions to 621.82 or greater
    • All other stemcells should be upgraded to the latest version available onĀ bosh.io.
  • CF Deployment
    • Upgrade All versions to v13.17.0 or greater

History

2020-09-24: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES