Cloud Foundry Logo
blog single gear
Security Advisory

USN-4250-2: MariaDB vulnerability




Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 18.04


It was discovered that an unspecified vulnerability existed in the C API component of MariaDB. An attacker could use this to cause a denial of service for MariaDB clients.

MariaDB has been updated to 10.3.22 in Ubuntu 19.10 and 10.1.44 in Ubuntu 18.04 LTS.

In addition to security fixes, the updated packages contain bug fixes, new features, and possibly incompatible changes.

CVEs contained in this USN include: CVE-2020-2570, CVE-2020-2572, CVE-2020-2573, CVE-2020-2574, CVE-2020-2577, CVE-2020-2579, CVE-2020-2584, CVE-2020-2588, CVE-2020-2589, CVE-2020-2627, CVE-2020-2660, CVE-2020-2679, CVE-2020-2686, CVE-2020-2694.

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • cflinuxfs3
    • All versions prior to 0.16.0
  • CF Deployment
    • All versions prior to 1.9.0


Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • cflinuxfs3
    • Upgrade All versions to 0.16.0 or greater
  • CF Deployment
    • Upgrade All versions to 1.9.0 or greater


2021-02-10: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR