Cloud Foundry Logo
blog single gear
Security Advisory

USN-4274-1: libxml2 vulnerabilities

USN-4274-1: libxml2 vulnerabilities

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 14.04
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04

Description

It was discovered that libxml2 incorrectly handled certain XML files. An attacker could possibly use this issue to cause a denial of service. (CVE-2019-19956, CVE-2020-7595)

CVEs contained in this USN include: CVE-2019-19956, CVE-2020-7595.

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • cflinuxfs3
    • All versions prior to 0.163.0
  • Xenial Stemcells
    • 621.x versions prior to 621.57
    • 456.x versions prior to 456.98
    • 315.x versions prior to 315.169
    • 250.x versions prior to 250.183
    • 170.x versions prior to 170.203
    • 97.x versions prior to 97.232
    • All other stemcells not listed.
  • CF Deployment
      • All versions prior to v12.33.0

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • cflinuxfs3
      • Upgrade All versions to 0.163.0 or greater
  • Xenial Stemcells
    • Upgrade 621.x versions to 621.57 or greater
    • Upgrade 456.x versions to 456.98 or greater
    • Upgrade 315.x versions to 315.169 or greater
    • Upgrade 250.x versions to 250.183 or greater
    • Upgrade 170.x versions to 170.203 or greater
    • Upgrade 97.x versions to 97.232 or greater
    • All other stemcells should be upgraded to the latest version available onĀ bosh.io.
  • CF Deployment
    • Upgrade All versions to v12.33.0 or greater

History

2020-02-10: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES