Cloud Foundry Logo
blog single gear
Security Advisory

USN-4333-1: Python vulnerabilities

USN-4333-1: Python vulnerabilities

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 14.04
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04

Description

It was discovered that Python incorrectly stripped certain characters from requests. A remote attacker could use this issue to perform CRLF injection. (CVE-2019-18348)

It was discovered that Python incorrectly handled certain HTTP requests. An attacker could possibly use this issue to cause a denial of service. (CVE-2020-8492)

CVEs contained in this USN include: CVE-2019-18348, CVE-2020-8492.

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • cflinuxfs3
    • All versions prior to 0.176.0
  • Xenial Stemcells
    • 170.x versions prior to 170.217
    • 250.x versions prior to 250.196
    • 315.x versions prior to 315.181
    • 456.x versions prior to 456.110
    • 621.x versions prior to 621.71
    • All other stemcells not listed.
  • CF Deployment
    • All versions prior to v13.0.0

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • cflinuxfs3
    • Upgrade All versions to 0.176.0 or greater
  • Xenial Stemcells
    • Upgrade 170.x versions to 170.217 or greater
    • Upgrade 250.x versions to 250.196 or greater
    • Upgrade 315.x versions to 315.181 or greater
    • Upgrade 456.x versions to 456.110 or greater
    • Upgrade 621.x versions to 621.71 or greater
    • All other stemcells should be upgraded to the latest version available onĀ bosh.io.
  • CF Deployment
    • Upgrade All versions to v13.0.0 or greater

History

2020-04-21: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES