Cloud Foundry Logo

USN-4377-1: ca-certificates update


Share

USN-4377-1: ca-certificates update

Severity

Unknown

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04

Description

The ca-certificates package contained an expired CA certificate that caused connectivity issues. This update removes the “AddTrust External Root” CA.

In addition, on Ubuntu 16.04 LTS and Ubuntu 18.04 LTS, this update refreshes the included certificates to those contained in the 20190110 package.

Affected Cloud Foundry Products and Versions

Severity is unknown unless otherwise noted.

  • cflinuxfs3
    • All versions prior to 0.190.0
  • Xenial Stemcells
    • 170.x versions prior to 170.221
    • 250.x versions prior to 250.200
    • 315.x versions prior to 315.185
    • 456.x versions prior to 456.114
    • 621.x versions prior to 621.76
    • All other stemcells not listed.
  • CF Deployment
    • All versions prior to v13.5.0

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • cflinuxfs3
    • Upgrade All versions to 0.190.0 or greater
  • Xenial Stemcells
    • Upgrade 170.x versions to 170.221 or greater
    • Upgrade 250.x versions to 250.200 or greater
    • Upgrade 315.x versions to 315.185 or greater
    • Upgrade 456.x versions to 456.114 or greater
    • Upgrade 621.x versions to 621.76 or greater
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • CF Deployment
    • Upgrade All versions to v13.5.0 or greater

References

History

2020-06-01: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES