Cloud Foundry Logo
blog single gear
Security Advisory

USN-4602-1: Perl vulnerabilities

Severity

Low

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04

Description

ManhND discovered that Perl incorrectly handled certain regular expressions. In environments where untrusted regular expressions are evaluated, a remote attacker could possibly use this issue to cause Perl to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2020-10543)

Hugo van der Sanden and Slaven Rezic discovered that Perl incorrectly handled certain regular expressions. In environments where untrusted regular expressions are evaluated, a remote attacker could possibly use this issue to cause Perl to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2020-10878)

Sergey Aleynikov discovered that Perl incorrectly handled certain regular expressions. In environments where untrusted regular expressions are evaluated, a remote attacker could possibly use this issue to cause Perl to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2020-12723)

CVEs contained in this USN include: CVE-2020-10878, CVE-2020-10543, CVE-2020-12723.

Affected Cloud Foundry Products and Versions

Severity is low unless otherwise noted.

  • cflinuxfs3
    • All versions prior to 0.211.0
  • Xenial Stemcells
    • 315.x versions prior to 315.201
    • 456.x versions prior to 456.128
    • 621.x versions prior to 621.92
    • All other stemcells not listed.
  • CF Deployment
    • All versions prior to 15.4.0

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • cflinuxfs3
    • Upgrade all versions to 0.211.0 or greater
  • Xenial Stemcells
    • Upgrade 315.x versions to 315.201 or greater
    • Upgrade 456.x versions to 456.128 or greater
    • Upgrade 621.x versions to 621.92 or greater
    • All other stemcells should be upgraded to the latest version available onĀ bosh.io.
  • CF Deployment
    • Upgrade all versions to 15.4.0 or greater

History

2021-03-09: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES