Cloud Foundry Logo
blog single gear

CVE-2021-22115: CAPI logs service broker credentials

Severity

Critical

Vendor

Cloud Foundry Foundation

Description

Cloud Controller API versions prior to 1.106.0 logs service broker credentials if the default value of db logging config field is changed. CAPI database logs service broker password in plain text whenever a job to clean up orphaned items is run by Cloud Controller. A malicious user with access to those logs may gain unauthorised access to service broker.

Affected Cloud Foundry Products and Versions

Severity is critical unless otherwise noted.

  • CAPI
    • All versions prior to 1.106.0
  • CF Deployment
    • All versions prior to 16.2.0

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • CAPI
    • Upgrade all versions to 1.106.0 or greater
  • CF Deployment
    • Upgrade all versions to 16.2.0 or greater

History

2021-03-30: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES