Cloud Foundry Logo
blog single gear
Security Advisory

USN-4968-1: LZ4 vulnerability

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 18.04

Description

It was discovered that LZ4 incorrectly handled certain memory operations. If a user or automated system were tricked into uncompressing a specially- crafted LZ4 file, a remote attacker could use this issue to cause LZ4 to crash, resulting in a denial of service, or possibly execute arbitrary code.

CVEs contained in this USN include: CVE-2021-3520.

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • Bionic Stemcells
    • 1.x versions prior to 1.10
    • All other stemcells not listed.
  • cflinuxfs3
    • All versions prior to 0.240.0
  • CF Deployment
    • All versions prior to 16.15.0

Mitigation

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • Bionic Stemcells
    • Upgrade 1.x versions to 1.10 or greater
    • All other stemcells should be upgraded to the latest version available onĀ bosh.io.
  • cflinuxfs3
    • Upgrade all versions to 0.240.0 or greater
  • CF Deployment
    • Upgrade all versions to 16.15.0 or greater

History

2021-06-11: Initial vulnerability report published.

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES