USN-3805-1: curl vulnerabilities

By: | November 20, 2018

Share

USN-3805-1: curl vulnerabilities

Severity

Medium

Vendor

Canonical Ubuntu

Versions Affected

  • Canonical Ubuntu 14.04
  • Canonical Ubuntu 16.04
  • Canonical Ubuntu 18.04

Description

Harry Sintonen discovered that curl incorrectly handled SASL authentication. A remote attacker could use this issue to cause curl to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2018-16839)

Brian Carpenter discovered that curl incorrectly handled memory when closing certain handles. A remote attacker could use this issue to cause curl to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2018-16840)

Brian Carpenter discovered that the curl command-line tool incorrectly handled error messages. A remote attacker could possibly use this issue to obtain sensitive information. (CVE-2018-16842)

CVEs contained in this USN include: CVE-2018-16839, CVE-2018-16840, CVE-2018-16842

Affected Cloud Foundry Products and Versions

Severity is medium unless otherwise noted.

  • Cloud Foundry BOSH trusty-stemcells are vulnerable, including:
    • 3586.x versions prior to 3586.54
    • 3541.x versions prior to 3541.59
    • 3468.x versions prior to 3468.86
    • 3445.x versions prior to 3445.81
    • 3421.x versions prior to 3421.98
    • All other stemcells not listed.
  • Cloud Foundry BOSH xenial-stemcells are vulnerable, including:
    • 170.x versions prior to 170.5
    • 97.x versions prior to 97.31
    • All other stemcells not listed.
  • All versions of Cloud Foundry cflinuxfs2 prior to 1.245.0
  • All versions of Cloud Foundry cflinuxfs3 prior to 0.34.0

Mitigation

Users of affected products are strongly encouraged to follow one of the mitigations below:

  • The Cloud Foundry project recommends upgrading the following BOSH trusty-stemcells:
    • Upgrade 3586.x versions to 3586.54
    • Upgrade 3541.x versions to 3541.59
    • Upgrade 3468.x versions to 3468.86
    • Upgrade 3445.x versions to 3445.81
    • Upgrade 3421.x versions to 3421.98
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • The Cloud Foundry project recommends upgrading the following BOSH xenial-stemcells:
    • Upgrade 170.x versions to 170.5
    • Upgrade 97.x versions to 97.31
    • All other stemcells should be upgraded to the latest version available on bosh.io.
  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs2 version 1.245.0 or later.
  • The Cloud Foundry project recommends that Cloud Foundry deployments run with cflinuxfs3 version 0.34.0 or later.

References

Cloud Foundry Foundation Security Team Profile Image

Cloud Foundry Foundation Security Team, AUTHOR

SEE ALL ARTICLES